Commit f072e768 authored by paul's avatar paul

Update to new debian stable

parent 9f563ac9
......@@ -3,22 +3,16 @@ MAINTAINER none
EXPOSE 80
RUN sed -i 's/main/main non-free/g' /etc/apt/sources.list
RUN echo 'deb http://download.videolan.org/pub/debian/stable/ /' >> /etc/apt/sources.list
RUN echo 'deb-src http://download.videolan.org/pub/debian/stable/ /' >> /etc/apt/sources.list
#RUN echo 'deb http://archive.ubuntu.com/ubuntu trusty main multiverse' >> /etc/apt/sources.list
RUN apt-get update
RUN DEBIAN_FRONTEND=noninteractive apt-get -y install wget
RUN wget -O - http://download.videolan.org/pub/debian/videolan-apt.asc | apt-key add -
RUN apt-get update
# Need this environment variable otherwise mysql will prompt for passwords
RUN DEBIAN_FRONTEND=noninteractive apt-get -y install apache2 wget php5 php5-json php5-curl php5-mysqlnd php5-ldap lame libvorbis-dev vorbis-tools flac libmp3lame-dev \
libavcodec-extra* libfaac-dev libtheora-dev libvpx-dev libav-tools git php5-gd
RUN \
php -r "readfile('https://getcomposer.org/installer');" | php \
&& mv composer.phar /usr/local/bin/composer
RUN DEBIAN_FRONTEND=noninteractive apt-get -y install \
apache2 wget php php-json php-curl php-mysql php-ldap lame \
libvorbis-dev vorbis-tools flac libmp3lame-dev libavcodec-extra* \
libfaac-dev libtheora-dev libvpx-dev libav-tools git php-gd composer
# installation
RUN rm -rf /var/www/html && \
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment